Important Online & Mobile Banking Alert: Minimum Browser Versions

Effective October 17, 2017 – To improve the security of our Online & Mobile Banking services, we will be upgrading the minimum supported web browser versions and operating systems. Please see below for specific details for your device or it is possible you may no longer be able to access your accounts via online or mobile banking after the deadline.

Online Banking
We will support the following minimum versions:
  • Google Chrome version 42
  • Mozilla Firefox version 31
  • Safari version 7
  • Internet Explorer Version 11
  • Microsoft Edge

Visit browsercheck.onlineaccounts.org to check if your browser is compatible with online banking.

If you are using an unsupported browser, please visit outdatedbrowser.com to download a supported browser.
Mobile Banking
If you are running a device with an older version operating system, you will no longer be able to access mobile banking through our Apple or Android apps.
  • Apple devices – Minimum Version is 9.0 – Visit support.apple.com for steps to check the operating system version and to update to the latest version of iOS.
  • Android devices – Minimum Version is 5.0 – Visit wikihow.com/Update-an-Android for steps to check the operating system version and to update to the latest version of the Android operating system.
For assistance with upgrading your particular device, we suggest you contact your cell phone carrier.